Issues with Sufio accounts
Incident Report for Sufio
Resolved
We have resolved the issue, and our services are now operating as normal.

Thank you for your patience throughout this process.
Posted Oct 28, 2021 - 16:31 UTC
Investigating
We are currently investigating an issue preventing some users from accessing their Sufio accounts.

We apologize for any inconvenience and will provide more updates as they become available.
Posted Oct 28, 2021 - 16:02 UTC
This incident affected: Sufio Accounts, Data Synchronization, Website, and Blog and Articles.